Reduce Google Chrome Browser Locking Or Crashing When Working with PDF Documents


This document provides steps to take to clean up the Google web browser to prevent locking/crashing when working with PDF documents.

 

 

 

Information

 

Symptoms

Google browser locking when downloading PDF documents from email, Google Drive, and attaching PDF documents.


Cause

The root cause has yet to be identified. This issue is created when users try downloading or uploading PDF documents to and from email, file folders, Google Drive folder and primarily attaching a PDF document.


Resolution

Making several settings adjustments in the browser and in the computer Default Application settings tends to help reduce / eliminate the effects of this issue. 

Go into the Google browser settings by CLICKING on the three dots in the upper right corner of the Chrome browser window.

 

Go to, SETTINGS> People> Sync and Google Services>Turn on

Help improve Chrome's features and performance

Automatically sends usage statistics and crash reports to Google

 

 

After that, go back into the browser SETTINGS and scroll down to ADVANCED.

Open Advanced, then go to Site Settings and the PDF Documents. Turn on PDF Documents. This tells the browser to user the computer's default PDF application to open PFD documents.

 

 

 

That completes changes in the Google Browser.

 

One other setting on the computer you should change is the Default Apps setting for .PDF .PDFXML and .PDX file types.

 In the search field on the bottom left of your desktop, TYPE in DEFAULT to access the Default Apps section of your PC.

 

 

 

 

Scroll down to bottom of the window and SELECT, Choose "default apps by file type".

 

 

Once selected, Scroll down to find the file types mentioned earlier, .PDF .PDFXML and .PDX. Click on each file type and change the default program that the documents will open with to Adobe Acrobat DC.

 

Changing these settings on your PC will help reduce or eliminate the Google browser from locking when downloading or uploading PDF documents.

 

 

 

 

Escalation

 

Any questions on process or content contained in this document should be escalated through the NCSU Help desk and a have an incident assigned to the OIT_DESKTOP_SUPPORT team. 

 

 

Related Documentation

 

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Title: Reduce Google Chrome Browser Locking Or Crashing When Working with PDF Documents
Service: OIT Managed Desktop Support Service
Template if applicable: None
Assignment Group(s): OIT_DESKTOP_SUPPORT
Document Owner: OIT_DESKTOP_SUPPORT
Available Priorities: High, Medium, Low 
Keywords:  Google, Browser, Chrome, Crashing